當前位置: 網站首頁 > 股票軟件公式 > 飛狐公式 > 文章 當前位置: 飛狐公式 > 文章

飛狐源碼:短線雙龍,五龍起舞

點擊: 次    來源:頂尖財經    作者:股市狙擊 - 小 + 大

短線雙龍:

這個公式特點:
短線操作KDJ結合波段趨勢。
疊加經典RSI,票票是走是留,決斷當時。
趨勢走向不看彩帶看零軸,一樣精準。
買與賣,三指標提示,再不會也沒治了。什么抄底,搶反彈,做中,長線,任意。
短線最常用的指標是KDJ,反應快,方向感強。
 
副圖直觀,簡單明了。
二十年自用,一圖走天下。好不好用,你說了算。
通達信等軟件只要對趨勢線語句稍加改動或隱藏或刪除,一樣通用。
 
 
 
源碼
 
RSV:=(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100; 
KO:=SMA(RSV,N1,1),Precision1;
DK:=SMA(KO,N2,1),Precision1;
JO:=3*KO-2*DK,Precision1;
FILLRGN(JO>90,JO,90),COLOR20E839;  
FILLRGN(JO<12,JO,12),COLORRED;  
FILLRGN(JO<>90,90,10),COLOR000000;
DRAWBAND(90,0,10,0);
J:JO,LINETHICK1,ColorWhite,Precision1;DRAWTEXT(ISLASTBAR,J,' J'),ColorWhite,LINETHICK16;
K:KO,COLORFF00FF,Precision1,nodraw;
D:DK,ColorGreen,Precision1,nodraw;
A2:=BARSLAST(REF(CROSS(KO,DK),1));
B2:=REF(C,A2+1)>C AND REF(KO,A2+1)<KO AND CROSS(KO,DK),coloryellow;
C2:=BARSLAST(REF(CROSS(DK,KO),1));
D2:=REF(C,C2+1)<C AND REF(KO,C2+1)>KO AND CROSS(DK,KO);
KDJ底背:=B2>0;
DRAWTEXT(B2>0,k*1.1,'   K底背'),COLORFF00FF;DRAWICON(B2>0,k*1.1,1);
KDJ頂背:=D2>0;DRAWTEXT(D2>0,k*1.2,'K頂背'),ColorGreen;
DRAWTEXT(CROSS(K,D),k*0.95,' K金'),ColorYellow;
RSI:SMA(MAX(c-REF(c,1),0),6,1)/SMA(ABS(c-REF(c,1)),6,1)*100,Precision0,COLORred;DRAWTEXT(ISLASTBAR,RSI,'       RSI'),ColorRed;
tja:=(2*C+H+L)/4;
tjb:=LLV(L,9);
tja1:=HHV(H,9);
BX:=EMA((tja-tjb)/(tja1-tjb)*100,8);
BX1:=EMA(BX,5);
DRAWBAND(BX,RGB(255,00,255),BX1,RGB(110,200,255));
短線多空:PARTLINE(bX>BX1,0),COLOR0000FF,LINETHICK2;DRAWTEXT(ISLASTBAR,短線多空,' 短線多空'),ColorBlue,LINETHICK15;
 PARTLINE(BX<=BX1,0),ColorGreen,LINETHICK2;
 DRAWTEXT(CROSS(BX,BX1),BX*0.95,' ↑▲反向'),ColorYellow;
TR1:=SMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(L-REF(C,1))),14,1);
HD:=H-REF(H,1);
LD:=REF(L,1)-L;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),14,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),14,1);
PDI:=DMP*100/TR1;
STICKLINE(RSI>90,0,30,0.5,0),ColorGreen;
DRAWTEXT(RSI>90,30*1.1,'!RIS'),ColorGreen;
 10,linedot;  90,linedot;




五龍起舞:

原創作品,利用經典CCI/KDJ/RSI/WR/MDI五大指標揭示股價規律,飛狐交易師軟件一類,都可以使用,不適用于通達信。( 頂尖財經 股票學院: http://www.243679.tw )

 
TYP:=(H+L+C)/3;   
CCIO:=(TYP-MA(TYP,9))/(0.015*AVEDEV(TYP,9)),NODRAW,PRECISION1;
FILLRGN(CCIO>150,CCIO,150),COLORFFFF00;   
FILLRGN(CCIO<-200,CCIO,-200),COLORA69AFA;   
FILLRGN(CCIO<>150,150,-200),COLOR000000;
RSV:=(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;  
KO:=SMA(RSV,N1,1),PRECISION1;
DK:=SMA(KO,N2,1),PRECISION1;
JO:=3*KO-2*DK,PRECISION1;
FILLRGN(JO>88,JO,88),COLOR20E839;   
FILLRGN(JO<12,JO,12),COLORRED;   
DRAWBAND(88,0,12,0);{區域無色}
CCI:CCIO,COLORYELLOW,PRECISION1,LINEDOT;DRAWTEXT(ISLASTBAR,CCI,'       CCI'),COLORYELLOW,LINETHICK16;
J:JO,LINETHICK1,COLORWHITE,PRECISION1;DRAWTEXT(ISLASTBAR,J,' J'),COLORWHITE,LINETHICK16;
K:KO,COLORFF00FF,PRECISION1,NODRAW;
D:DK,COLORGREEN,PRECISION1,NODRAW;
A2:=BARSLAST(REF(CROSS(KO,DK),1));
B2:=REF(C,A2+1)>C AND REF(KO,A2+1)<KO AND CROSS(KO,DK),COLORYELLOW;
C2:=BARSLAST(REF(CROSS(DK,KO),1));
D2:=REF(C,C2+1)<C AND REF(KO,C2+1)>KO AND CROSS(DK,KO);
KDJ底背:=B2>0;
DRAWTEXT(B2>0,K*1.1,'   K底背'),COLORFF00FF;DRAWICON(B2>0,K*1.1,1);
KDJ頂背:=D2>0;DRAWTEXT(D2>0,K*1.1,'K頂背'),COLORFFCC66;
DRAWTEXT(CROSS(K,D),K*0.95,' K金'),COLORYELLOW;
RSI:SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100,PRECISION0,COLORRED;DRAWTEXT(ISLASTBAR,RSI,'       RSI'),COLORRED;
R1:=SMA(CCIO,3,1);   
D1:=SMA(R1,3,1);   
J1:=3*R1-2*D1;   
RR1:=EMA(J1,5);   
RR2:=REF(RR1,1);
RR:=RR1>RR2;
買:=RR AND NOT(REF(RR,1)) AND (RR1<-130 AND RR1<-130),LINETHICK0;DRAWTEXT(買,CCIO*0.95,'↑B'),LINETHICK17,COLORRED;
賣:=REF(RR,1)=1 AND NOT(RR) AND RR1>100,LINETHICK0;DRAWTEXT(賣,CCIO*0.95,'↓S'),LINETHICK16,COLORGREEN;
TJA:=(2*C+H+L)/4;
TJB:=LLV(L,9);{9-34D}
TJA1:=HHV(H,9);{9-34D}
BX:=EMA((TJA-TJB)/(TJA1-TJB)*100,8);
BX1:=EMA(BX,5);{分析家公式網}
{STICKLINE(BX-BX1>0,BX,BX1,8,1),COLORRED;
STICKLINE(BX-BX1<0,BX,BX1,8,1),COLOR00FF00;}
DRAWBAND(BX,RGB(255,00,255),BX1,RGB(110,200,255));
短線多空:PARTLINE(BX>BX1,0),COLOR0000FF,LINETHICK2;DRAWTEXT(ISLASTBAR,短線多空,' 短線多空'),COLORBLUE,LINETHICK15;
PARTLINE(BX<=BX1,0),COLORGREEN,LINETHICK2;
DRAWTEXT(CROSS(BX,BX1),BX*0.95,' ↑▲反向'),COLORYELLOW;
TR1:=SMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(L-REF(C,1))),14,1);
HD:=H-REF(H,1);
LD:=REF(L,1)-L;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),14,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),14,1);
PDI:=DMP*100/TR1;
STICKLINE(RSI>88,0,50,0.5,0),COLORGREEN;
DRAWTEXT(RSI>88,50*1.1,'!RIS'),COLORGREEN;

上一篇:飛狐源碼:分水嶺

下一篇:飛狐源碼:分時主圖,macd結構副圖

推薦閱讀
广东11选5最容易中奖