當前位置: 網站首頁 > 股票軟件公式 > 飛狐公式 > 文章 當前位置: 飛狐公式 > 文章

飛狐公式源碼:傻瓜交易副圖

點擊: 次    來源:頂尖財經    作者:股市狙擊 - 小 + 大

多空指標只要分得清紅綠就會操作,一看就懂。

四條線粉或紅色時買入持股,有一條綠或二條綠線時短線賣出。
五條指標線綜合了多項技術指標,同時區分長線、中線和短線三種不同工作方式操作。
最上層線為短線波段工作指標,中間1條紅綠線為成交量多空線。下層2條指標線分別為中線和長線工作參考線。
這么簡潔明白的指標,你到時哪去找?什么MACD、RSI,CCI,WR,KDJ,MDI,BOLL......統統不用研究了。
你對照一下個股的走勢看看吧,好用不好用,準確率如何,你說了算!( 頂尖財經 股票學院: http://www.243679.tw )
我的指標都是自用自編,決不抄錄、決不改編他人的成果。

只用于飛狐。想在通達信中引用,得改編。
{1}
tja:=(2*C+H+L)/4;
tjb:=LLV(L,9);
tja1:=HHV(H,9);
BX:=EMA((tja-tjb)/(tja1-tjb)*100,8);
BX1:=EMA(BX,5);
PARTLINE(bX>BX1,2),COLOR0000FF,LINETHICK5;DRAWTEXT(ISLASTBAR,2,' 短波段'),ColorYellow;
PARTLINE(BX<=BX1,2),ColorGreen,LINETHICK5;
{2}
Mm1:=EMA(C,7);Mm2:=EMA(C,21);
MD1:= Mm1-Mm2;
MM:=EMA(MD1,5);
PARTLINE( MD1>=MM AND MD1<0,1.5),COLORMAGENTA, LINETHICK5;DRAWTEXT(ISLASTBAR,1.5,' 短線'),COLORRED;
PARTLINE( MD1>=MM AND MD1>=0,1.5),COLORRED, LINETHICK5;
PARTLINE( MD1<MM AND MD1>=0,1.5), COLORGREEN, LINETHICK5;
PARTLINE( MD1<MM AND MD1<0,1.5),COLORWHITE, LINETHICK5;
 {3} 
EME13:=EMA(EMA(C,21),21);
XLPL:=(EME13-REF(EME13,1))/REF(EME13,1)*1000;
XLM5:=(MA(C,5)/REF(MA(C,5),1)-1)*1000;
MV10:=MA(V,90); 
var1:=ref(v,1)>MV10 and ref(v,2)>MV10 and ref(v,3)>MV10;
VAR2:=(ref(v,1)+ref(v,2)+ref(v,3))/3;
PARTLINE(XLPL<0 AND XLM5>0,1),COLORFF00FF,LINETHICK5;DRAWTEXT(ISLASTBAR,1,' 量線'),COLORFFFF00;
PARTLINE(VAR2>=1.0*MV10 and VAR2<1.3*MV10,1),COLORFF00FF,LINETHICK5;
PARTLINE(XLPL>=0 AND XLM5>0,1),COLORRED,LINETHICK5;
PARTLINE(VAR2>=1.3*MV10,1),COLORred,LINETHICK5;
PARTLINE(XLPL>=0 AND XLM5<=0,1),COLORGREEN,LINETHICK5;
PARTLINE(VAR2<1.0*MV10,1),ColorGreen,LINETHICK5;
PARTLINE(XLPL<0 AND XLM5<=0,1),COLORWHITE,LINETHICK5;
{3}
PARTLINE(XLPL<0 AND XLM5>0,0.5),COLORFF00FF,LINETHICK5;
DRAWTEXT(ISLASTBAR,0.5,' 中線'),COLORFFFFFF;
PARTLINE(XLPL>=0 AND XLM5>0,0.5),COLORRED,LINETHICK5;
PARTLINE(XLPL>=0 AND XLM5<=0,0.5),COLORGREEN,LINETHICK5;
PARTLINE(XLPL<0 AND XLM5<=0,0.5),COLORWHITE,LINETHICK5;
{4長線}
MIB:=(2*CLOSE+LOW+OPEN+HIGH)/5;
長線:=(20*MIB+19*REF(MIB,1)+18*REF(MIB,2)+17*REF(MIB,3)+16*REF(MIB,4)+15*REF(MIB,5)+14*REF(MIB,6)+13*REF(MIB,7)+12*REF(MIB,8)+11*REF(MIB,9)+
10*REF(MIB,10)+9*REF(MIB,11)+8*REF(MIB,12)+7*REF(MIB,13)+6*REF(MIB,14)+5*REF(MIB,15)+4*REF(MIB,16)+3*REF(MIB,17)+2*REF(MIB,18)+REF(MIB,20))/210;
PARTLINE(長線>REF(長線,1),0),LINETHICK5,COLORRED;DRAWTEXT(ISLASTBAR,-0.2,'  長線'),COLORFF00FF;
PARTLINE(長線<REF(長線,1),0),LINETHICK5,COLORGREEN;

上一篇:飛狐公式源碼:擒大主力資金

下一篇:飛狐公式源碼:全景看盤

推薦閱讀
广东11选5最容易中奖