當前位置: 網站首頁 > 股票軟件公式 > 大智慧L2公式 > 文章 當前位置: 大智慧L2公式 > 文章

大智慧源碼:騰龍通道,動量買賣,黃金操盤,跟莊到頂主圖

點擊: 次    來源:頂尖財經    作者:股市狙擊 - 小 + 大

1、騰龍通道

     上去:=ema(c,3); 

       下來:=ema(c,5); 
          中間:=ema(下來,3);
     FILLRGN(上去,下來,上去>REF(上去,1)),color0098FF,PRECIS2;
        FILLRGN(上去,下來,上去<REF(上去,1)),color00FF00,PRECIS2;
     PARTLINE(中間,中間>ref(中間,1),rgb(255,0,128),中間<=ref(中間,1),rgb(27,71,250)),linethick1,PRECIS0,LAYER0;
      Hj:=(o+h+l+c)/4;
      Hj1:=EMA(Hj,5);
     Hj2:=REF(Hj1,1);
          金線:=IF(Hj1>=Hj2,Hj1,Hj2)*1.02;   Hj3:=IF(Hj2-Hj1,Hj2,Hj1)*1.02;
     PARTLINE(金線,金線>Hj3,rgb(255,0,0),Hj3=金線,rgb(89,255,89)),linethick1,PRECIS2,LAYER0;



2、動量買賣

{動量買賣}

VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
S:=SMA(VAR1,5,1);
VAR2:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
X:SMA(VAR2,2,1),COLORFF00FF ;
VR4:=SMA(ABS(L-REF(L,1)),13,1)/SMA(MAX(L-REF(L,1),0),13,1);
底部動量:IF(EMA(IF(L<=LLV(L,30),VR4,0),3)*10<100,EMA(IF(L<=LLV(L,30),VR4,0),3)*10,100),COLOR004DF5;
AA:=INTPART(底部動量);
DD:=IF(AA>REF(HHV(AA,120),1),AA,0);
VR2:=LLV(LOW,10);
VR3:=HHV(HIGH,25);
動力線:=IF(EMA((CLOSE-VR2)/(VR3-VR2)*4,4)*25<100,EMA((CLOSE-VR2)/(VR3-VR2)*4,4)*25,100);
STICKLINE(動力線>REF(動力線,1) ,動力線 ,REF(動力線,1),4 ,0),COLORRED;
STICKLINE(動力線<=REF(動力線,1) ,動力線 ,REF(動力線,1),4 ,1),COLOR00FF00;
CDP :=(HIGH + LOW + 2*CLOSE)/4;
買入價:(2*CDP-HIGH),COLORRED , LINETHICK0 ;
賣出價:(2*CDP-LOW) ,COLORWHITE, LINETHICK0 ;
VAR3:=1/WINNER(CLOSE);
VAR4:=EMA(CLOSE,13);
VAR5:=100-ABS((CLOSE-VAR4)/VAR4)*100;
黃金坑:=(100-IF(VAR3>10,IF(VAR3<100,VAR3,VAR5-90),0));
100,POINTDOT;
70,POINTDOT;
30,POINTDOT,COLORFF00FF ;
VAR1A:=WINNER(CLOSE); 
VAR2A:=VOL/CAPITAL; 
VAR3A:=VAR2A/VAR1A; 
JJ:=IF(VAR1A<50/100 ,VAR3A,0)*100; 
財神線:=IF(JJ<100,JJ,0);
STICKLINE(財神線>=0,0,底部動量,0.0005,0),POINTDOT,COLOR00FFFF;
JHH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);
STICKLINE(ABS(JHH/WINNER(C))>1000000000,0,0,0,0),COLORFF00FF,LINETHICK5;
DRAWTEXT((S-X)>=70 AND X<7,10,'★'),COLORRED;
VARC:=CLOSE*50/100;
VARD:=MA(VARC,30)*0.83;
VARE:=MA(VARC/VARD,3);
DRAWTEXT(FILTER(VARE<1.04,3),10,'★'),COLORYELLOW ;
DRAWTEXT(CROSS(X,底部動量) AND 動力線>REF(動力線,1) AND C>L*1.03,100,'★'),COLORGREEN;
DRAWTEXT(X>動力線*2 AND X>=80,90,'●');




3、黃金操盤,重心和平衡

{黃金操盤}

重心:(C+0.618*REF(C,1)+0.382*REF(C,2)+0.236*REF(C,3)+0.146*REF(C,4))/2.382,COLORRED,LINETHICK1;
GAO:=HHV(C,60)-LLV(C,60);
RSI:=SMA(MAX(重心-REF(重心,1),0),5,1)/SMA(ABS(重心-REF(重心,1)),5,1);
指導線:重心+GAO*(RSI-0.5),COLORMAGENTA,LINETHICK1;
平衡:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);
PARTLINE(平衡,重心>=平衡,RGB(255,0,0),重心<平衡,RGB(0,255,0)),LINETHICK2;



4、跟莊到頂主圖

{跟莊到頂主圖}

VAR4:=(LOW+HIGH+CLOSE)/3;
操作: MA(VAR4,5);
拉升: HHV(操作,13);
壓力: HHV(操作,60);
買賣: LLV(操作,13);
底部支撐: LLV(LOW,60)*1.02;
頂部: HHV(HIGH,60)*0.98;

上一篇:大智慧精選下載組合公式5個

下一篇:大智慧公式精選:波段彩云,競價分筆排序,獵豹85

广东11选5最容易中奖