當前位置: 網站首頁 > 股票軟件公式 > 同花順公式 > 文章 當前位置: 同花順公式 > 文章

同花順源碼精選:強者恒強主圖,趨勢頂底波段,資金老馬

點擊: 次    來源:頂尖財經    作者:股市狙擊 - 小 + 大

1、強者恒強主圖

M1:=MA(CLOSE,1);
M2:=(LOW+HIGH+CLOSE)/3;
M3:= MA(M2,5);
M4:= HHV(M3,11);
Z:=HHV((M1<M4),10) OR HHV((M1<M4),10);
S:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,35)-LLV(LOW,34)),3);
VAR5:MA(CLOSE,5);
VAR13:MA(CLOSE,13);
VAR21:MA(CLOSE,21);
VAR60:MA(CLOSE,60);
VAR144:MA(CLOSE,144);
VAR4:=OPEN<VAR5 OR OPEN<VAR13 OR OPEN<VAR21;
VAR51:=CLOSE>MAX(VAR5,MAX(VAR13,MAX(VAR21,VAR60)));
VAR6:=VOL/MA(VOL,30)>1.2;
VAR7:=CLOSE/REF(CLOSE,1)>1.049;
VAR8:=VAR4 AND VAR51 AND VAR6 AND VAR7;
VAR9:=VAR8 AND (REF(BARSLAST(VAR8),1)>60 OR BARSSINCE(VAR8)=0);
DRAWICON(VAR9 ,L*0.98,1) ;
DRAWICON( FILTER(CROSS(S,60 ),20),L*0.96,7),coloryellow ;
STICKLINE( S>60,H,L,0,1) ,colorred;
STICKLINE( S>60,O,C,2,1) ,colorred;
STICKLINE( S<60,H,L,0,1) ,colorgreen;
STICKLINE( S<60,O,C,2,1) ,colorgreen;
STICKLINE( VAR9,H,L,0,1) ,coloryellow;
STICKLINE( VAR9,O,C,2,1) ,coloryellow;


2、趨勢頂底波段

DRAWGBK(C>0, RGB(50,60,250),RGB(17,21,89),0,'11',0);
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,colorgreen;
支撐:=L1+P1*0.5/8,colorred;
中線:=(支撐+阻力)/2,colorwhite,POINTDOT;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趨勢線:EMA(V11,3),LINETHICK2,colorlimagenta;
V12:=(趨勢線-REF(趨勢線,1))/REF(趨勢線,1)*100;
準備買入:STICKLINE(趨勢線<11,趨勢線,11,5,0),coloryellow;
AA:=(趨勢線<11) AND FILTER((趨勢線<=11),15) AND C<中線;
BB0:=REF(趨勢線,1)<11 AND CROSS(趨勢線,11) AND C<中線;
BB1:=REF(趨勢線,1)<11 AND REF(趨勢線,1)>6 AND CROSS(趨勢線,11);
BB2:=REF(趨勢線,1)<6 AND REF(趨勢線,1)>3 AND CROSS(趨勢線,6);
BB3:=REF(趨勢線,1)<3 AND REF(趨勢線,1)>1 AND CROSS(趨勢線,3);
BB4:=REF(趨勢線,1)<1 AND REF(趨勢線,1)>0 AND CROSS(趨勢線,1);
BB5:=REF(趨勢線,1)<0 AND CROSS(趨勢線,0);
BB:=BB1=1 OR BB2=1 OR BB3=1 OR BB4=1 OR BB5=1;
下單買入:STICKLINE(BB=1 AND C<中線,11,50,5,0),colorred;
DRAWICON(BB=1 AND C<中線,55,1);
準備賣出:STICKLINE(趨勢線>89,趨勢線,89,5,0),colorwhite;
CC:=(趨勢線>89) AND FILTER((趨勢線>89),15) AND C>中線;
DD0:=REF(趨勢線,1)>89 AND CROSS(89,趨勢線) AND C>中線;
DD1:=REF(趨勢線,1)>89 AND REF(趨勢線,1)<94 AND CROSS(89,趨勢線);
DD2:=REF(趨勢線,1)>94 AND REF(趨勢線,1)<97 AND CROSS(94,趨勢線);
DD3:=REF(趨勢線,1)>97 AND REF(趨勢線,1)>99 AND CROSS(97,趨勢線);
DD4:=REF(趨勢線,1)>99 AND REF(趨勢線,1)<100 AND CROSS(99,趨勢線);
DD5:=REF(趨勢線,1)>100 AND CROSS(100,趨勢線);
DD:=DD1=1 OR DD2=1 OR DD3=1 OR DD4=1 OR DD5=1;
下單賣出:STICKLINE(DD=1 AND C>中線,89,50,5,0),colorgreen;
DRAWICON(DD=1 AND C>中線,45,2);
頂:89,colorgreen;
底:11,colorred;
中:50,POINTDOT,colorwhite;
DRAWTEXT(ISLASTBAR,頂,'頂'),colorgreen;
DRAWTEXT(ISLASTBAR,底,'底'),colorred;
DRAWTEXT(ISLASTBAR,中,'中'),colorwhite;



3、資金老馬( 股民學院: http://www.243679.tw )

VAR1:=HHV(HIGH,9)-LLV(LOW,9);

VAR2:=HHV(HIGH,9)-C;
VAR3:=C-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(C-LLV(LOW,44))/(HHV(HIGH,44)-LLV(LOW,44))*100;
VAR6:=(2*C+H+L)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,21);
VAR9:=SMA(VAR7 ,3 ,1 )-SMA(VAR4 ,9 ,1);
VAR10:=IF(VAR9>100 ,VAR9-100 ,0 );
VAR11:=HHV(HIGH,21);
VAR12:=EMA((VAR6- VAR8)/(VAR11-VAR8)*100,9 );
VAR13:=EMA(0.667*REF(VAR12 ,1) +0.333*VAR12,2 );
資金:=EMA(100*(C-LLV(LOW,21))/(HHV(H,21)-LLV(LOW,21)),3), colorred,LINETHICK3;
PARTLINE(資金,資金>REF(資金,1),RGB(250,10,10),資金<=REF(資金,1),RGB(10,250,250)),LINETHICK3;
資金線:=EMA(100*(C-LLV(LOW,21))/(HHV(H,21)-LLV(LOW,21)),3), coloryellow,LINETHICK1;
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF (ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF (ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF (ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF (ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF (ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF (ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
買入:(VAR11+VAR13+VAR15+VAR17)*18,colorf00ff0,LINETHICK2;
賣出:=(VAR12+VAR14+VAR16+VAR18)*18,color00ff00,LINETHICK2;
VAR30:=PEAKBARS(3,15,1)<10;
VAR50:=IF(VAR30=1,2,0);
頂:= IF(VAR50=2,2,0);
頂A:=IF(頂>REF(頂,1),50,0),colorgreen;
S1:=SMA((CLOSE-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3))*100,5,1);
趨勢線:SMA(EMA(((C+L)/2-LLV(L,21))/(HHV((H+C)/2,21)-LLV(L,21))*100,3),7,1),LINETHICK2;
升:IF(趨勢線>=REF(趨勢線,1),趨勢線,DRAWNULL),COLORFF00FF,LINETHICK2;
降:IF(趨勢線<=REF(趨勢線,1),趨勢線,DRAWNULL),COLOR00FF00,LINETHICK2;
趨勢:SMA(EMA(((C+L)/2-LLV(L,21))/(HHV((H+C)/2,21)-LLV(L,21))*100,3),7,1),colorwhite,LINETHICK1;
VC:=(2*C+H+L)/4;
VD:=LLV(L,34);
VE:=HHV(H,34);
VF:=LLV(L,21);
V10:=HHV(H,21);
V11:=EMA((VC-VF)/(V10-VD)*100,5);
V12:=EMA((VC-VD)/(VE-VD)*100,8);
V13:=EMA(V12,5);
STICKLINE(V12>0 AND (V12-V13)>=0 ,80 ,78 ,6 ,0 ),COLORFF00FF;
STICKLINE(V12>0 AND (V12-V13)<0 ,80 ,78 ,6 ,1 ),COLOR00FF00;
STICKLINE(V12>0 AND (V12-V13)>=0 ,20 ,18 ,6 ,0 ),COLORFF00FF;
STICKLINE(V12>0 AND (V12-V13)<0 ,20 ,18 ,6 ,1 ),COLOR00FF00;
N=50.0000000009,1.0000000009,100.0000000009,1;
M1=5.0000000009,1.0000000009,40.0000000009,1;
M2=10.0000000009,1.0000000009,40.0000000009,1;
LG=240.0000000009,1.0000000009,2300.0000000008999,1;
N54=12.0000000009,1.0000000009,5000.0000000009004,1;
RSV=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
a=SMA(RSV,M1,1);
b=SMA(a,M2,1);
e=3*a-2*b;
kkk:=100;
K:=MA(a,3);
D:=MA(b,3);
J:=MA(e,3);
VarB1:=ZIG(3,96/N54);
烏云:IF( REF(varB1,2)<REF(varB1,1) AND varB1<REF(varB1,1),75,100),colorFF8000,LINETHICK3;
賣出:IF( REF(varB1,2)<REF(varB1,1) AND varB1<REF(varB1,1),75,100),colorwhite,LINETHICK1;
DRAWICON(REF(varB1,2)<REF(varB1,1) AND varB1<REF(varB1,1),73,"sell");
獵豹: IF(REF(VarB1,2)>REF(VarB1,1) AND VarB1>REF(VarB1,1),25,0),color8000FF,LINETHICK3;
買入: IF(REF(VarB1,2)>REF(VarB1,1) AND VarB1>REF(VarB1,1),25,0),coloryellow,LINETHICK1;
DRAWICON(REF(VarB1,2)>REF(VarB1,1) AND VarB1>REF(VarB1,1),28,"buy");
MV5:=IF(BARSCOUNT(CLOSE)<5,MA(V,BARSCOUNT(CLOSE)),MA(V,5));
MV13:=IF(BARSCOUNT(CLOSE)<13,MA(V,BARSCOUNT(CLOSE)),MA(V,13));
MV21:=IF(BARSCOUNT(CLOSE)<21,MA(V,BARSCOUNT(CLOSE)),MA(V,21));
MV34:=IF(BARSCOUNT(CLOSE)<34,MA(V,BARSCOUNT(CLOSE)),MA(V,34));
MV55:=IF(BARSCOUNT(CLOSE)<55,MA(V,BARSCOUNT(CLOSE)),MA(V,55));
MV89:=IF(BARSCOUNT(CLOSE)<89,MA(V,BARSCOUNT(CLOSE)),MA(V,89));
MV144:=IF(BARSCOUNT(CLOSE)<144,MA(V,BARSCOUNT(CLOSE)),MA(V,144));
MV233:=IF(BARSCOUNT(CLOSE)<233,MA(V,BARSCOUNT(CLOSE)),MA(V,233));
GL1:=IF(VOL>MV5*2,1,0);
GL2:=IF(VOL>MV13*2,1,0);
GL3:=IF(VOL>MV21*2,1,0);
GL4:=IF(VOL>MV34*2,1,0);
GL5:=IF(VOL>MV55*2,1,0);
GL6:=IF(VOL>MV89*2,1,0);
GL7:=IF(VOL>MV144*2,1,0);
GL8:=IF(VOL>MV233*2,1,0);
DL1:=IF(VOL<MV5/2,1,0);
DL2:=IF(VOL<MV13/2,1,0);
DL3:=IF(VOL<MV21/2,1,0);
DL4:=IF(VOL<MV34/2,1,0);
DL5:=IF(VOL<MV55/2,1,0);
DL6:=IF(VOL<MV89/2,1,0);
DL7:=IF(VOL<MV144/2,1,0);
DL8:=IF(VOL<MV233/2,1,0);
GL:=GL1+GL2+GL3+GL4+GL5+GL6+GL7+GL8;
DL:=DL1+DL2+DL3+DL4+DL5+DL6+DL7+DL8;
放量出貨:GL*5,color00FF00,LINETHICK2;
低量類別:=DL;
 

上一篇:同花順精選下載組合公式17個

下一篇:同花順源碼精選:主力動向+主力趨勢雷達,趨勢公式

广东11选5最容易中奖