當前位置: 網站首頁 > 股票軟件公式 > 通達信公式 > 文章 當前位置: 通達信公式 > 文章

通達信源碼精選:金鷹主圖,機構內部指標,瘋顛布林主圖

點擊: 次    來源:頂尖財經    作者:股市狙擊 - 小 + 大

1、金鷹主圖

DRAWBAND(MA(C,60),RGB(55,0,0),MA(C,120),RGB(0,90,0));

DRAWBAND(MA(CLOSE,60),RGB(155,5,50),MA(CLOSE,120),RGB(83,168,68));
DRAWBAND(MA(CLOSE,5),RGB(255,80,50),MA(CLOSE,10),RGB(68,100,80));  
MA5:MA(CLOSE,5),COLORWHITE; 
MA10:MA(CLOSE,10),COLORYELLOW; 
MA20:MA(CLOSE,20),COLORMAGENTA; 
MA40:=MA(CLOSE,40);
MA60:MA(CLOSE,60),COLORGREEN; 
MA120:MA(CLOSE,120),COLORLIMAGENTA; 
MA240:MA(CLOSE,240),COLORBLUE; 
DRAWKLINE(H,O,L,C); 
DRAWICON(CROSS(MA10,MA20),MA20,1); {10日上穿20日做記號} 
DRAWICON(CROSS(MA20,MA60),MA60,1); {20日上穿60日做記號} 
DRAWICON(CROSS(MA20,MA120),MA120,1); {20日上穿60日做記號} 
DRAWICON(CROSS(MA20,MA240),MA240,1);{20日上穿120日做記號} 
DRAWICON(CROSS(MA60,MA120),MA60,1); {60日上穿120日做記號} 
DRAWICON(CROSS(MA60,MA240),MA240,1); {60日上穿240日做記號} 
DRAWICON(CROSS(MA120,MA240),MA240,1);{120日上穿240日做記號} 
 
DRAWICON(CROSS(MA20,MA10),MA20,2); {10日下穿20日做記號} 
DRAWICON(CROSS(MA60,MA20),MA60,2); {20日下穿60日做記號} 
DRAWICON(CROSS(MA120,MA60),MA60,2); {60日下穿120日做記號} 
反彈托:=MA5>MA20 AND MA5>MA20 AND MA20<MA60 AND MA60<MA120 AND CROSS(MA10,MA20); 
月價托:=MA5>MA20 AND MA20>MA60 AND MA60>MA120 AND MA5>MA20 AND CROSS(MA10,MA20); 
季價托:=MA20>MA60 AND MA20>MA60 AND CROSS(MA20,MA60); 
短長價托:=MA5>MA60 AND MA5>MA10 AND CROSS(MA10,MA60); 
半年托:=MA60>MA120 AND MA60>MA120 AND CROSS(MA60,MA120); 
熊來:=MA60<MA120 AND MA60<MA120 AND CROSS(MA120,MA60); 
年托:=MA120>MA240 AND MA120>MA240 AND CROSS(MA120,MA240); 
月蜘蛛:=MA5>MA10 AND MA10>MA20 AND CROSS(MA5,MA20)AND CROSS(MA10,MA20); 
 
DRAWTEXT(月蜘蛛,MA20-0.22,'金蜘蛛'),COLORMAGENTA; 
DRAWTEXT(反彈托,MA20-0.12,'反彈托'),COLORMAGENTA; 
DRAWTEXT(月價托 ,MA20-0.02,'月托'),COLORMAGENTA; 
DRAWTEXT(季價托,MA60-0.1,'季托'),COLORMAGENTA; 
DRAWTEXT(短長價托,L+0.3,'短長托'),COLOR36C0C1; 
DRAWTEXT(半年托,MA120-0.08,'牛市來'),COLORRED; 
DRAWTEXT(熊來,MA60+0.08,'小心熊'),COLORGREEN; 
DRAWTEXT(年托,MA240-0.12,'年托'),COLORRED; 
壓:=MA10<MA20 AND MA20>MA10 AND CROSS(MA20,MA10); 
DRAWTEXT(壓,MA20+0.05,'月壓'),COLORYELLOW; 
VOL5:=MA(VOL,5),COLORWHITE; 
VOL10:=MA(VOL,10),COLORYELLOW; 
VOL40:=MA(VOL,40),COLORFF00FF ; 
量托:=VOL5>=VOL40 AND CROSS(VOL10,VOL40) AND REF(VOL10,1)<REF(VOL40,1); 
DRAWTEXT(量托,L-0.1,'量托'),COLORWHITE; 
AA1:=BARSLAST(MA60>MA20 AND (MA20=MA10 OR MA20>MA10)); 
BB1:=REF(COUNT(C<MA60,AA1)=AA1,1); 
CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3; 
芙蓉出水:=BB AND CC1,COLOR00FF00; 
DRAWTEXT(芙蓉出水,H+0.12,'芙蓉出水'),COLORFF00FF; 
STICKLINE(芙蓉出水,H,L,0.5,1),COLORFF00FF; 
STICKLINE(芙蓉出水,O,C,4,1),LINETHICK2,COLORFF00FF; 
 
 
MA1:=MA(CLOSE,5); 
MA2:=MA(CLOSE,10); 
MA3:=MA(CLOSE,30); 
ZJ:=AMOUNT/10000;{資金} 
 
一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1<C AND MA2<C AND MA3<C AND CLOSE>OPEN ; 
DRAWTEXT(一穿三,L-0.018,'穿三線'),COLORFF00FF; 
C6:=REF(C,1); 
漲停:=IF((C-C6)*100/C6>=(10-0.01*100/C6),1,0); 
STICKLINE(漲停,OPEN,CLOSE,3,0),COLORYELLOW; 
STICKLINE(漲停,H,L,0,0),COLORYELLOW; 
{壓力一} 
TY:=C; 
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10); 
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10); 
前期高位:REF(C,BARSLAST(HD)),COLOR00FF00,POINTDOT; 
STICKLINE(C,前期高位,前期高位,8,0),COLORYELLOW;
CX:=HHV(C,60),COLORGREEN,LINETHICK2;
 
五順第一陽:=C>MA5 AND MA5>MA10 AND MA10>MA20 AND MA20>MA60 AND MA60>MA120;
金桔:=五順第一陽 AND REF(NOT(五順第一陽),1) AND C>REF(C,1);
DRAWICON(金桔,H*1.046,17);
五上第一陽:=C>MAX(MA5,MAX(MA10,MA20)) AND MA60>MA120 AND C>MA60;
三星:=五上第一陽 AND REF(NOT(五上第一陽),1) AND C>REF(C,1);
DRAWICON(三星,H*1.028,18);
五上第一陽1:=C>MAX(MA5,MAX(MA10,MA20)) AND C>MAX(MA60,MA120) AND NOT(MA60>MA120);
青蘋果:=五上第一陽1 AND REF(NOT(五上第一陽1),1) AND C>REF(C,1);
DRAWICON(青蘋果,H*1.0,16); 
三順第一陽:=C>MA5 AND MA5>MA10 AND MA10>MA20;
桔:=三順第一陽 AND REF(NOT(三順第一陽),1) AND C>REF(C,1);
DRAWICON(桔,H*0.95,23);
三上第一陽:=C>MAX(MA5,MAX(MA10,MA20));
星:=三上第一陽 AND REF(NOT(三上第一陽),1) AND C>REF(C,1);
DRAWICON(星,H*0.93,22);
前期低位:=REF(C,BARSLAST(LD)),COLORFF00FF,POINTDOT;
STICKLINE(C,前期低位,前期低位,5,0),COLORFF00FF;
收盤價:IF(C,CONST(C),DRAWNULL),COLORMAGENTA,DOTLINE;



2、機構內部指標

JRH:=HHV(C,2);

JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
紅色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
機構離場:=IF(紅色持股,JRL,DRAWNULL);
明離場價:=機構離場,COLORFF99FF,NODRAW;
今離場價:REF(機構離場,1)COLOR0000FF,NODRAW;
青色觀望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
進:=IF(青色觀望,JRH,DRAWNULL);
明進場價:=進,COLOR33AACC,NODRAW;
今進場價:REF(明進場價,1),COLORFF0000,NODRAW;
機構短買:VAR19,COLOR33AACC,NODRAW;
品紅離場:VAR1A,COLORFF99FF,NODRAW;
急速超跌:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;
辰星線:(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211,COLOR0000FF;
牽牛線:MA(CLOSE,26),COLORFF00FF;
等待:=IF(MA3>辰星線,辰星線,MA3);
上市日期年:REF(YEAR,BARSCOUNT(CLOSE)-1),NODRAW,COLOR0000FF;
月:REF(MONTH,BARSCOUNT(CLOSE)-1),NODRAW,COLORFF00FF;
日:REF(DAY,BARSCOUNT(CLOSE)-1),NODRAW,COLOR00FFFF;
IF(等待>REF(等待,1),等待,DRAWNULL),LINETHICK2,COLOR00FFFF;
IF(辰星線>REF(辰星線,1),辰星線,DRAWNULL),LINETHICK2,COLOR0000FF;
IF(辰星線<REF(辰星線,1),辰星線,DRAWNULL),COLOR00FF00;
IF(牽牛線>REF(牽牛線,1),牽牛線,DRAWNULL),LINETHICK1,COLORFF00FF;
IF(牽牛線<REF(牽牛線,1),牽牛線,DRAWNULL),COLOR669933;
STICKLINE(ISLASTBAR AND (紅色持股 OR REF(紅色持股,1)=1),今離場價,今離場價,30,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (青色觀望 OR REF(青色觀望,1)=1),今進場價,今進場價,30,1),COLOR00FF00;
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
STICKLINE(紅色持股,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(紅色持股,CLOSE,O,2,0),COLOR000088;
STICKLINE(紅色持股,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(紅色持股,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(紅色持股,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(青色觀望,CLOSE,O,2.8,0),COLOR555500;
STICKLINE(青色觀望,CLOSE,O,2,0),COLOR888800;
STICKLINE(青色觀望,CLOSE,O,1.5,0),COLORAAAA00;
STICKLINE(青色觀望,CLOSE,O,1,0),COLORCCCC00;
STICKLINE(青色觀望,CLOSE,O,0.5,0),COLOREEEE00;
CO:=(C-O);
STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;
STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;
STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;
STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;
STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;
STICKLINE(機構短買,O,O+CO/3,2.8,0),COLOR335555;
STICKLINE(機構短買,O,O+CO/3,2,0),COLOR338888;
STICKLINE(機構短買,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(機構短買,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(機構短買,O,O+CO/3,0,0),COLOR33EEEE;
DRAWTEXT(機構短買,REF(CLOSE,1),'←機構短買'),COLOR33FFCC;
STICKLINE(品紅離場,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(品紅離場,O,O+CO/3,2,0),COLOR880088;
STICKLINE(品紅離場,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(品紅離場,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(品紅離場,O,O+CO/3,0.5,0),COLOREE00EE;
DRAWTEXT(品紅離場,REF(CLOSE,1)+0.1,'←機構離場'),COLORFF99FF;
{股民學院 www.243679.tw 整理}



3、瘋顛布林主圖

 {瘋顛布林}

N:=20;
BOLL:MA(CLOSE,N);
UB:BOLL+2*STD(CLOSE,N);
LB:BOLL-2*STD(CLOSE,N);
UB角度:ATAN((UB/REF(UB,1)-1)*100)*180/3.1416,NODRAW;
BOLL角度:ATAN((BOLL/REF(BOLL,1)-1)*100)*180/3.1416,NODRAW;
LB角度:ATAN((LB/REF(LB,1)-1)*100)*180/3.1416,NODRAW;
AALB:REF(LB角度,1),NODRAW;
IF(BOLL角度>35,BOLL,DRAWNULL),COLORYELLOW,LINETHICK3,NODRAW;
IF(BOLL角度>53,BOLL,DRAWNULL),COLORGREEN,LINETHICK3,NODRAW;
AAA:=(C-UB)/UB*100,NODRAW;
ABCC:=REF(BOLL角度,1)>3 AND UB角度>23 AND BOLL角度>7 AND LB角度<-5 AND LB角度<0 AND AAA>3 {AND REF(C,1)>REF(UB,1)} AND C>UB;
DRAWTEXT(ABCC AND IF(COUNT(ABCC,2)>1 AND V>REF(V,1),0,1) AND UB角度<79 AND REF(UB角度,1)<79 AND REF(UB角度,2)<78 ,L,'瘋牛2瘋牛2瘋牛2'),COLORGREEN;
DRAWTEXT( C>UB AND REF(C,1)<REF(UB,1) AND REF(C,2)<REF(UB,2) AND REF(C,3)<REF(UB,3) AND V>2.5*LLV(V,3) AND V>REF(V,1) AND C>O AND C>REF(C,1) AND UB角度<70,L,'開始顛了'),COLORGREEN;
DRAWTEXT( C>UB AND REF(C,1)<REF(UB,1) AND REF(C,2)<REF(UB,2) AND REF(C,3)<REF(UB,3) AND V>2.5*LLV(V,3) AND V>REF(V,1) AND C>O AND C>REF(C,1) AND UB角度<70,LB,'開始顛了'),COLORRED;

上一篇:通達信源碼精選:趨勢線,小散盯盤,精準短波

下一篇:通達信源碼精選:精準追漲逃頂,攻擊量能,東風導彈

广东11选5最容易中奖