當前位置: 網站首頁 > 股票軟件公式 > 通達信公式 > 文章 當前位置: 通達信公式 > 文章

通達信源碼精選:精準追漲逃頂,攻擊量能,東風導彈

點擊: 次    來源:頂尖財經    作者:股市狙擊 - 小 + 大

1、精準追漲逃頂,追漲和逃頂組合在一起

精準追漲的公式見過,精準逃頂的公式少見,

追漲和逃頂組合在一起,配合使用。

追漲1:C>REF(C,1)*1.09 AND C*1.2<MA(C,90),LINETHICK3;
追漲2:C>REF(C,1)*1.09 AND V*1.02<REF(V,1),LINETHICK3;
A1:=EMA(CLOSE,5);
A2:=EMA(CLOSE,10);
A3:=EMA(CLOSE,20);
追漲3:IF(CROSS(A1,A2) AND CROSS(C,A3),1,0),LINETHICK3;
VAR2:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100;
VAR3:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR4:=IF(VAR2>1,0.9,1.2);
VAR5:=VAR4*(VAR3-VAR2)*1.382;
VAR6:=SUM(VAR5,25)+SUM(VAR5,10)+SUM(VAR5,5);
逃頂:VAR6>50 AND COUNT(VAR6>50,10)=1 AND VAR3>3,LINETHICK3;
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
VAR10:=7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+REF(HHJSJDA,20);
VAR11:=17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6) 
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12);
HHJSJDB:=(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+VAR11+VAR10)/210;
HHJSJDC:=MA(HHJSJDB,5);
QQ1:=MA(MA(CLOSE,3),3);
QQ2:=MA(MA(CLOSE,15),9);
XYSQS1:=(QQ1-REF(QQ1,1))/REF(QQ1,1)*100;
XYSQS2:=(QQ2-REF(QQ2,1))/REF(QQ2,1)*100;
XYSHSL:=EMA(VOL/CAPITAL*100,13);
STICKLINE(XYSQS2>=REF(XYSQS2,1)AND XYSHSL>1 AND C>HHJSJDB AND HHJSJDB>HHJSJDC,0,0.4,4,0),COLORRED;



2、攻擊量能

以前發布過兩個公式:籌碼初探和暴漲時機,今天研究量能,給大家報告一些結果。
量能在許多人的心目中是比較在意認為是重要的,俺首先計算了陽線量能和陰線量能,然后找他們的規律。具體的大家就看圖了,不多說。
量能累積到一定的程度導致大幅上漲的。
【測試結果】結果是這樣是一個參考的,具體下面圖例里面有操作方法

【三四主圖通達信源碼】
MA3:MA(C,3);
MA4:MA(C,4);
IF(MA3>=REF(MA3,1),MA3,DRAWNULL)COLORRED LINETHICK2;
IF(MA3<REF(MA3,1),MA3,DRAWNULL)COLORGREEN LINETHICK2;

{攻擊量能}
YAV:=IF(C>REF(C,1),VOL,DRAWNULL);
YIV:=IF(C<REF(C,1),VOL,DRAWNULL);
YAVS:=SUM(YAV,5)/5;
YIVS:=SUM(YIV,5)/5;
JL:YAVS-YIVS,COLORSTICK;
ZL:REF(JL,1);
DRAWTEXT(FILTER(JL=HHV(JL,80),20) AND C>MA(C,20),JL,'買'),COLORYELLOW;
STICKLINE(FILTER(JL=HHV(JL,80),20) AND C>MA(C,20),0,JL,1,1) COLORRED;
STICKLINE(FILTER(JL=HHV(JL,80),20) AND C>MA(C,20),0,JL*0.5,1,O) COLORGREEN;
{股民學院 www.243679.tw 整理}



3、東風導彈

導彈來了,娛樂公式

主力: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2;
見底信號:=10, LINETHICK2,COLORRED ;
{買入時機1: IF(CROSS(主力,見底信號),100,10),LINETHICK2,COLORYELLOW;}
追漲: 50,POINTDOT;
VAR10:CROSS(主力,見底信號);
STICKLINE(VAR10,37,  39,    4.4,0),COLORYELLOW;
STICKLINE(VAR10,33,    37,    5,0),COLORYELLOW;
STICKLINE(VAR10,28,     33,       6,0),COLORYELLOW;
STICKLINE(VAR10,10,    28,       7,0),COLORYELLOW;
STICKLINE(VAR10,98,  100,   0.5,0),COLORYELLOW;
STICKLINE(VAR10,96,  98,   1.5,0),COLORYELLOW;
STICKLINE(VAR10,93,  96,    3,0),COLORYELLOW;
STICKLINE(VAR10,89,    93,     4,0),COLORYELLOW;
STICKLINE(VAR10,75,     89,       5,0),COLORYELLOW;
STICKLINE(VAR10,8,     75,       4,0),COLORYELLOW;
{火焰}
STICKLINE(VAR10,9,     5,        5,0),COLOR0000FF;
STICKLINE(VAR10,5,    0,       4,0),COLOR0000FF;
STICKLINE(VAR10,-5,     0,       3,0),COLOR0000FF;
STICKLINE(VAR10,-10,     -5,      2,0),COLOR0000FF;
STICKLINE(VAR10,-10,     -15,      1,0),COLOR0000FF;
STICKLINE(VAR10,-15,     -20,       0.5,0),COLOR0000FF;
STICKLINE(VAR10,8,     5,        2,0),COLOR00FFFF;
STICKLINE(VAR10,5,    0,       1,0),COLOR00FFFF;
STICKLINE(VAR10,-5,     0,      0.25,0),COLOR00FFFF;
{字體及五星紅旗}
STICKLINE(VAR10,85,   80,     3,0),COLOR0000FF;
{DRAWTEXT(VAR10,83,'★'),COLORYELLOW;}
STICKLINE(VAR10,67,   69,     1,0),COLORYELLOW;
STICKLINE(VAR10,59,   61,     1,0),COLORYELLOW;
STICKLINE(VAR10,51,  53,     1,0),COLORYELLOW;
STICKLINE(VAR10,43,  45,     1,0),COLORYELLOW;
{鋼圈}
STICKLINE(VAR10,89, 89,     4,0),COLORFF0000;
STICKLINE(VAR10,75, 75,     4,0),COLORFF0000;
STICKLINE(VAR10,39, 39,     4,0),COLORFF0000;
STICKLINE(VAR10,10, 10,    6,0),COLORFF0000;
 
DRAWTEXT(VAR10,65, '東'),COLORFF0000;
DRAWTEXT(VAR10,50, '風'),COLORFF0000;
DRAWTEXT(VAR10,30, '導'),COLORFF0000;
DRAWTEXT(VAR10,17, '彈'),COLORFF0000;

上一篇:通達信源碼精選:金鷹主圖,機構內部指標,瘋顛布林主圖

下一篇:通達信源碼精選:筷子夾肉形態,黃金錢包,長期線短期線,兩點買入

广东11选5最容易中奖