當前位置: 網站首頁 > 股票軟件公式 > 通達信公式 > 文章 當前位置: 通達信公式 > 文章

通達信源碼精選:筷子夾肉形態,黃金錢包,長期線短期線,兩點買入

點擊: 次    來源:頂尖財經    作者:股市狙擊 - 小 + 大

1、筷子夾肉形態

公式介紹:
技術形態叫:紅燒肉形態
所謂紅燒肉形態就是,兩根長筷子夾著一塊小的紅燒肉。在下跌行情末期,特別是加速下跌后,如果你看到這樣的線型,就肯定有一塊小肉吃。

T:=DYNAINFO(17)>0;
Q:=IF(NAMELIKE('S'),0,1);
R:=IF(NAMELIKE('*'),0,1);
M:=WINNER(REF(C,1))*100<10;
Z:=C/REF(C,1)>1.05;
S:=(C-REF(C,3))/REF(C,3)*100<10;
K:=REF(C,1)<O AND C>=((REF(O,1)-REF(C,1))*0.5+REF(C,1));
紅燒肉1:= K AND M AND T AND R  AND Q AND Z AND S;
A1:=REF(C,2)/REF(C,3)<0.96 AND REF(O,2)/REF(C,2)>1.05;
A2:=BETWEEN(REF(O,1)/REF(C,2),1.02,0.98);
A3:=BETWEEN(O/REF(O,1),1.02,0.98) AND C/REF(C,1)>1.05 AND C/O>1.05;
紅燒肉2:=A1 AND A2 AND A3;
XG:紅燒肉1 OR 紅燒肉2;
 

2、黃金錢包

{黃金錢包}

AAA:=(3*C+H+L+O)/6;

VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;

VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;

VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;

VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;

VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;

VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;

STICKLINE(VAR1>VAR6,VAR1,VAR6,0.5,0),COLORFF00FF;

STICKLINE(C>=O,C,O,3,0),COLOR000045;

STICKLINE(C>=O,C,O,2,0),COLOR000085;

STICKLINE(C>=O,C,O,1,0),COLOR0000E5;

STICKLINE(C>=O,H,L,0,0),COLOR0000F5;

STICKLINE(C<O,C,O,3,0),COLOR353500;

STICKLINE(C<O,C,O,2,0),COLOR555500;

STICKLINE(C<O,C,O,1,0),COLOR858500;

STICKLINE(C<O,H,L,0,0),COLOR959500;

短線:VAR1,COLORWHITE;

中線:VAR6,COLORYELLOW;



3、長期線短期線

長期線短期線 的源碼是:

R1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*200;
R2:=EMA((CLOSE-(LLV(LOW,5)))/((HHV(HIGH,5))-(LLV(LOW,5)))*100,4)*2;
R3:=EMA(0.618*REF(R2,1)+0.382*R2,2);
R4:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
R5:=POW(MA(LOW,5),2)+MA(LOW,5);
R6:=POW(MA(HIGH,5),2)+MA(HIGH,5);
R7:=(R4-LLV(R5,64))/(HHV(R6,64)-LLV(R5,64))*150+65-10;
R8:=SMA((SMA(R7,3,1)*1.5-100),3,1);
R9:=3*(SMA(R7,3,1)*1.5-100)-2*R8;
R10:=(HIGH+LOW+CLOSE*2)/4;
R11:=(R10-(EMA(R10,13)))*100/(STD(R10,13));
R12:=EMA((EMA(R11,5)),13)+200-100;
R13:=(SMA(R1,3,1))+R2+(SMA(R7,3,1)*1.5-100)+R12;
R14:=(SMA((SMA(R1,3,1)),3,1))+R3+R8+(EMA(R12,10));
R15:=(3*(SMA(R1,3,1))-2*(SMA((SMA(R1,3,1)),3,1)))+(3*R12-2*(EMA(R12,10)))+R9+(3*R12-2*(EMA(R12,10)));
R16:=(HIGH+LOW+CLOSE)/3;
R17:=(R16-MA(R16,34))/(0.015*AVEDEV(R16,34));
R18:=(HIGH+LOW+CLOSE+R16)/4;
R19:=(R18-(EMA(R18,24)))/(STD(R18,24))*100;
R20:=(R16-MA(R16,24))/(0.015*AVEDEV(R16,24));
R21:=(((EMA(R19,5))+R20+R17)/3+165)/4;
R22:=(R13+R14+R15*30)/32/5-15;
短期線: EMA(((R21+R22)/2/1.3),1),COLORMAGENTA,LINETHICK2;
長期線:MA(短期線,4),COLORYELLOW,LINETHICK2;
{股民學院 www.243679.tw 整理}



4、兩點買入

{公式名稱: 兩點買入

公式描述: 
參數數量: 9
參數1: RQ1, 最小: 1990, 最大: 3000, 缺省: 2019
參數2: RQ2, 最小: 1, 最大: 12, 缺省: 9
參數3: RQ3, 最小: 1, 最大: 31, 缺省: 16
參數4: RQA, 最小: 1990, 最大: 3000, 缺省: 2019
參數5: RQB, 最小: 1, 最大: 12, 缺省: 8
參數6: RQC, 最小: 1, 最大: 31, 缺省: 6
參數7: XG, 最小: 0, 最大: 3, 缺省: 2
參數8: HF, 最小: 0, 最大: 1, 缺省: 1
參數9: GF, 最小: 0, 最大: 5, 缺省: 0
公式類型: 技術指標公式-其他類型
畫線方法: 主圖疊加
公式源碼:}
 
X_1:=(RQ1-1900)*10000+RQ2*100+RQ3;
X_2:=REF(HIGH,BARSLAST(DATE<=X_1));
高價:IF(DATE>=X_1 AND XG>=1,X_2,DRAWNULL),COLORYELLOW;
X_3:=(RQA-1900)*10000+RQB*100+RQC;
X_4:=REF(LOW,BARSLAST(DATE<=X_3));
DRAWTEXT(ISLASTBAR,X_2,236),COLORRED;
低價:IF(DATE>=X_3 AND XG>=1,X_4,DRAWNULL),COLORCYAN;
STICKLINE(DATE<=X_1,低價,高價,0,0),COLORGREEN;
STICKLINE(DATE<=X_3,低價,高價,0,0),COLORMAGENTA;
X_5:=(高價-(高價-X_4)*0.74806)/高價;
X_6:=(高價-(高價-X_4)*0.2609)/高價;
C1:IF(DATE>=X_3 AND XG>=2,X_2*X_6,DRAWNULL),COLORMAGENTA,LINETHICK2;
X_7:=高價*低價;
C2:SQRT(X_7),COLORMAGENTA,LINETHICK2;
C3:IF(DATE>=X_3 AND XG>=2,X_2*X_5,DRAWNULL),COLORMAGENTA,LINETHICK2;
X_8:=IF(HF,DATE<=X_1,DATE<=X_3);
DRAWNUMBER(X_8,高價*X_6*1,高價*X_6),COLORYELLOW;
DRAWNUMBER(X_8,高價*X_5*1,高價*X_5),COLORYELLOW;
DRAWNUMBER(X_8,SQRT(X_7)*1,SQRT(X_7)),COLORYELLOW;

上一篇:通達信源碼精選:精準追漲逃頂,攻擊量能,東風導彈

下一篇:通達信精選下載組合公式8個

广东11选5最容易中奖